Jump to content
TrainTeamBerlin
Christopher Lange

Pluspack für die BR294 funktioniert nicht mit einem Repaint

Recommended Posts

Hallo Zusammen,

ich habe mir bei RailSim ein Repaint für die BR294 (dirty) gedownloaded und mittels Utilitiies installiert. Jetzt habe ich zwar das Repaint zur Auswahl, aber die Features des Pluspacks sind nicht vorhanden, Sound etc.

Geht das überhaupt mit einem Repaint? Muss man da noch etwas anderes machen außer die rwp.Datei installieren? Ich habe in der Readme des Repaints nichts gefunden und hier im Forum vergeblich nach einem Eintrag gesucht, der dieses Thema schon mal behandelt hat.

 

Gruß,

Christopher

Share this post


Link to post

Hallo Christopher,

 

nein, so einfach funktioniert das nicht mit jedem Repaint. Es müssen in das Engine-Blueprint einige geänderte Verlinkungen eingetragen werden. Prinzipiell kann das jeder für sich selbst nachrüsten - das funktioniert bspw. indem man ein Dateivergleichstool ranzieht und mit einer PlusPacklok vergleicht, wo andere Sound- oder Skiptdateien im Blueprint verlinkt sind.

 

Angepasste Blueprints für einige 294er-Repaints sind aber auch hier schon vorgefertigt: http://www.dw-agency.de/downloads/sound_ttb/freeware/

 

Viele Grüße,

Benjamin

Share this post


Link to post

Hallo Benjamin,

 

danke für Deine Hinweise und superschnellen Support!

Ich werde das mal so probieren und mir auch den Hinweis auf dw-agency.de anschauen.

 

Schönen Abend noch und viele Grüße,

 

Christopher

Share this post


Link to post

Hallo zusammen,

 

ich habe die Repaints erfolgeich auf das PlusPack umrüsten können, jedoch fehlt mir vorne im "Rangiergang" die Spitzenbeleuchtung.

Habt Ihr da ggf. auch eine Lösung zu??

 

Grüße,

Tobias

Share this post


Link to post

Hallo Tobias,

 

was genau fehlt denn - die als leuchtend zu erkennende Lampe oder der Lichtschein vor der Lok? Dann wöre auch die Frage, ob sich das grunsätzlich von der im Addon mitgelieferten Kuju-294 unterscheidet oder ob alle Maschinen betroffen sind. Falls nur die Repaints betroffen sind, würde ich sicherstellen, dass das 3d-Modell des Repaints auf dem gleichen Stand ist wie das der Kuju-294 (musste die .GeoPcDx händisch beim Installieren des Repaints kopiert werden?). Auch ist die Frage, ob es für das betroffene Repaint eine Anpassung im Goodie-Katalog gibt (wenn ja: um welche geht es?).

 

Viele Grüße,

Benjamin

Share this post


Link to post

Hallo,

 

es bezieht sich auf dieses Repaint mit der RK900.

 

https://rail-sim.de/forum/wsif/index.php/Entry/845-BR294-mit-RK900/

 

Die Geo.pdcx musste nicht händisch kopiert werden, diese ist enthalten.

Habe es aber dennoch verucht, ohne Erfolg.

 

Die LM am Führerstand leuchten, die Spitzensignale sind "aus".

Wenn man diese über die Lichtschalter verwenden, funktioniert es ordnungsgemäß.

 

Siehe Bild:

https://www.dropbox.com/sh/y5b6ww5u2wocael/AAByq5fabokjsPOYbZpcXZP7a?dl=0

 

Leider habe ich keine Ahnung vom Scrippen oder so, daher kann ich die Fragen nur bedingt beantworten.

 

Grüße,

Tobias

Share this post


Link to post

Hallo Tobias,

 

ich habe mir das betreffende Repaint einmal angesehen und das Fahrzeug-Blueprint durch einen Dateivergleich gejagt: gegenüber der PlusPack-Vorlage fehlt das verlinkte Kind-Objekt "Spitzenlicht" im Repaint. Ob das ein Versehen ist, oder ob der Autor damit etwas spezielles bezweckt, weiß ich nicht :eyebrow: Dass das Spitzenlicht sich beim Repaint anders verhält, liegt also nahe. Genauso, dass man das Child-Object händisch im Repaint-Fahrzeug selbst wieder ergänzt.

 

Dazu wäre das Fahrzeug-Blueprint ..\RailWorks\Assets\Kuju\RailSimulator\RailVehicles\Diesel\BR294\RangierGK\Engine\br294.bin mit der serz.exe aus dem Railworks-Hauptverzeichnis in eine XML-Datei umzuwandeln. Dann wird in der XML im Bereich <Children> folgender Eintrag ergänzt:

 

					<cEntityContainerBlueprint-sChild d:id="59167837">
							<ChildName d:type="cDeltaString">Spitzenlicht</ChildName>
							<BlueprintID>
								<iBlueprintLibrary-cAbsoluteBlueprintID>
									<BlueprintSetID>
										<iBlueprintLibrary-cBlueprintSetID>
											<Provider d:type="cDeltaString">Kuju</Provider>
											<Product d:type="cDeltaString">RailSimulator</Product>
										</iBlueprintLibrary-cBlueprintSetID>
									</BlueprintSetID>
									<BlueprintID d:type="cDeltaString">RailVehicles\Diesel\BR294\Default\TTB_CabLit\TTB_BR294_Spitzenlicht.xml</BlueprintID>
								</iBlueprintLibrary-cAbsoluteBlueprintID>
							</BlueprintID>
							<Matrix>
								<cHcRMatrix4x4>
									<Element>
										<e d:type="sFloat32" d:alt_encoding="000000000000F03F" d:precision="string">1</e>
										<e d:type="sFloat32" d:alt_encoding="0000000000000000" d:precision="string">0</e>
										<e d:type="sFloat32" d:alt_encoding="0000000000000000" d:precision="string">0</e>
										<e d:type="sFloat32" d:alt_encoding="0000000000000000" d:precision="string">0</e>
										<e d:type="sFloat32" d:alt_encoding="0000000000000000" d:precision="string">0</e>
										<e d:type="sFloat32" d:alt_encoding="000000000000F03F" d:precision="string">1</e>
										<e d:type="sFloat32" d:alt_encoding="0000000000000000" d:precision="string">0</e>
										<e d:type="sFloat32" d:alt_encoding="0000000000000000" d:precision="string">0</e>
										<e d:type="sFloat32" d:alt_encoding="0000000000000000" d:precision="string">0</e>
										<e d:type="sFloat32" d:alt_encoding="0000000000000000" d:precision="string">0</e>
										<e d:type="sFloat32" d:alt_encoding="000000000000F03F" d:precision="string">1</e>
										<e d:type="sFloat32" d:alt_encoding="0000000000000000" d:precision="string">0</e>
										<e d:type="sFloat32" d:alt_encoding="0000000000000000" d:precision="string">0</e>
										<e d:type="sFloat32" d:alt_encoding="0000000000000000" d:precision="string">0</e>
										<e d:type="sFloat32" d:alt_encoding="0000000000000000" d:precision="string">0</e>
										<e d:type="sFloat32" d:alt_encoding="000000000000F03F" d:precision="string">1</e>
									</Element>
								</cHcRMatrix4x4>
							</Matrix>
							<ParentNodeName d:type="cDeltaString"></ParentNodeName>
						</cEntityContainerBlueprint-sChild>

 

Schließlich die XML-Datei mit der serz.exe wieder zum .bin-Fahrzeugblueprint umwandeln. Das war's schon ;)

 

Viele Grüße,

Benjamin

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Furthermore you accept the Privacy Policy and the Terms of Use with using the forum.